Kinetiscope’s Main Window

This section introduces you to features in Kinetiscope's main window. All of Kinetiscope's main functions are accessed here.

The main window displays subwindows called scheme windows, each presenting one of the reaction schemes currently open in Kinetiscope. Reaction steps, reaction conditions and simulation settings may be entered or modified using the tabbed pages within each scheme window. Each different type of reaction scheme is presented with a scheme window specialized for that type.

The main window may also contain subwindows called results windows, which provide a view of the output of a simulation. You may create multiple results windows to examine different aspects of the simulation results. Different types of results windows can be created, depending on the characteristics of the reaction scheme you have constructed.

Only one subwindow may be active at any time. The active window is indicated by highlighting of its title bar. You activate a subwindow by clicking with the left mouse button when the mouse cursor is positioned over the window.

The main window includes a menu bar with pull-down menus, and a tool bar with push buttons. You use these to create new reaction schemes, load saved schemes, and control the contents of the main window. Menu items and push buttons whose actions are not allowed for the currently active subwindow are disabled and appear greyed out.

The important features of the main window are illustrated here.

Click on the captions in this figure to learn the details of each feature.


The Menu Bar

When you click on a menu bar command with the mouse button, a pull-down menu is displayed where you access a set of related commands. Four pull-down menus control all of Kinetiscope's main window functions: the File, Edit, Window and Help menus.

File menu

The File menu allows you to create, save and retrieve reaction scheme files. A reaction scheme file contains the complete description of a reaction scheme and the results from the most recently run simulation. The menu item

New...
constructs and initializes a new reaction scheme in memory. You specify the type of reaction scheme by your selection in the submenu available here. There are three different types of simulations that can be created by Kinetiscope: a single reactor model, a compartmental model, and a three-dimensional model. The characteristics of these three models, and the steps you take to create a new model, are described in the help section titled Constructing a New Reaction Scheme.
Open...
displays a File Open Dialog where you can select an existing reaction scheme file to load into memory.
Open Examples...
displays a File Open Dialog where you can load into memory one of the example reaction scheme files distributed with Kinetiscope.
Import...
opens a dialog where you can import a reaction file from CKS (the Chemical Kinetics Simulator program developed by IBM Research) into Kinetiscope as a new reaction scheme.
Open Recent...
displays a submenu listing the most recently used reaction scheme files. Select one of the file names to reload that scheme.
Close
removes the currently active reaction scheme from memory. If the reaction scheme has been changed since last saved as a file, you are given the opportunity to save the modified reaction scheme to file or to discard any modifications.
Close All
applies the Close action to all reaction schemes currently open in Kinetiscope.
Revert to Saved...
allows you to discard any modifications made to a reaction scheme since it was last saved to file, and reloads the original reaction scheme file into memory.
Save
saves the active reaction scheme to file using its current name. This option is not active if the reaction scheme has not been modified since it was last saved.
Save As...
saves the active reaction scheme to file under a new name. The original reaction scheme is closed, and the newly named reaction scheme replaces it in memory. If a simulation has been carried out using the original reaction scheme, the results are preserved in the new reaction scheme file.
Exit
ends your Kinetiscope session. If a simulation is currently running, a message box warning you of this appears; you may choose to cancel the shutdown process, or to abort the running simulation and continue wiht the shutdown. If any of the reaction schemes in memory have been modified since last saved to file, another message box appears, giving you the opportunity to save the changes to file, discard the changes, or cancel the shutdown process.

Edit menu

The Edit menu has two actions:

Application Options..
opens up the Application Options Dialog where the user may change certain application features.
Clear the Clipboard
For some actions, Kinetiscope's behavior will depend on the type of the item most recently placed on the clipboard by a Cut or Copy action. This menu selection allows you to empty Kinetiscope's clipboard if necessary.

Window menu

Cascade
resizes all the subwindows and arranges them in an overlapping arrangement with the window titles visible.
Tile
resizes all the subwindows and arranges them to fill the available space in the main window.
Tile Horizontally
resizes all the subwindows and arranges them to fill the available space in the main window, from left to right.
Tile Vertically
resizes all the subwindows and arranges them to fill the available space in the main window, from top to bottom.
A list of all open windows
is appended to this submenu. You may make one of the open windows the active window by selecting it from this list.

Help menu

Table of Contents
opens the Kinetiscope Help document to the Table of Contents.
Example Simulations
opens the Kinetiscope Help document to a table of all example simulations distributed with Kinetiscope.
Context Help
opens the Kinetiscope Help document to a page providing information on the current active subwindow or dialog.
About...
opens a dialog that shows detailed version information and legal notices. On Macintosh, this menu item is found under the Kinetiscope submenu added by the operating system.

The Main Tool Bar

The main tool bar provides a more direct route for performing some actions available from the File menu on the main menu bar. A tool tip containing brief explanatory text of each push button's function will appear when hovering the mouse pointer over the push button.

The push buttons initiate the following actions:

open recent button Open Recent... open  button Open...
open example button Open Examples... button Create a single-reactor scheme...
button Create a compartmental scheme... button Create a three-dimensional scheme...
button Save button Save As...
button Revert close button Close
close all button Close All help button Context Help